Παρασκευή, 18 Ιανουαρίου 2013

Παραδείγματα διαδικασιών LOGO



Διαδικασίες  για διάφορα σχέδια

Βασική διαδικασία
Πως την εκτελώ στο κέντρο ελέγχου
…με μεταβλητές
Πως την εκτελώ στο κέντρο ελέγχου
για τετράγωνο
στκ
επανάλαβε 4[μπ 100 δε 90]
τέλος
τετράγωνο
για τετράγωνο  :πλευρά
στκ
επανάλαβε 4[μπ  :πλευρά δε 90]
τέλος
π.χ.
τετράγωνο 70  
για τρίγωνο
στκ
επανάλαβε 3[μπ 100 δε 120]
τέλος
τρίγωνο
για τρίγωνο :πλευρά
στκ
επανάλαβε 3[μπ  :πλευρά δε 120]
τέλος
π.χ.
τρίγωνο 50
για σπίτι
τετράγωνο
μπ 100
δε 30
τρίγωνο
αρ 30
πι 100
τέλος
σπίτι
για σπίτι  :πλευρά
τετράγωνο :πλευρά
μπ :πλευρά
δε 30
τρίγωνο :πλευρά
αρ 30
πι :πλευρά
τέλος
π.χ.
σπίτι 200
για κύκλος
στκ
επανάλαβε 360[μπ 1 δε 1]
τέλος
κύκλος
για κύκλος  :τόξο
στκ
επανάλαβε 360[μπ  :τόξο  δε 1]
τέλος
π.χ.
κύκλος 2